Back to overview
Degraded

Dallas Attack

Apr 21 at 05:38pm EDT

Resolved
Apr 21 at 05:55pm EDT

This is believed to be fully resolved, we aren't seeing any more downtime or high latency on the network.

Updated
Apr 21 at 05:44pm EDT

We have been informed the attacks have been mitigated. We will continue to monitor our servers.

Created
Apr 21 at 05:38pm EDT

The data center of our Dallas Location is under a large-scale DDOS Attack and the data center is working on mitigating it as we speak. We will provide more updates as we get them.